jueves, 1 de septiembre de 2016

Clúster con CNO borrado en Directorio Activo. - Cluster where the CNO has been erased in AD.

Hola.

A continuación os voy a detallar una solución a un problema grave, como es encontrarnos que se ha borrado el equipo (CNO) objeto de clúster en el directorio activo.

La solución oficial la podéis seguir aquí:

Aunque en mi caso, esta solución o es válida porque me he encontrado que el objeto, no es recuperable con ADRestore y por tanto, he tenido que comprender e intentar suplantar el objeto borrado a base de prueba y error.

Pasos:

1. Lo primero va a ser crear un objeto con el mismo nombre que el que debería existir, en la misma OU donde están los nodos del clúster. En mi cas este es el objeto con nombre "Exchange".


2. Vamos a dar permisos en la OU aud contiene el objeto, tanto a el, como a los nodos del clúster.
    - Permiso a añadir el de crear objetos: Create all child objects.



3. Vamos a copiarnos la clave Hexadecimal del atributo ObjectGUID


4. Vamos a ver la clave "ClústerNameResource" que encontramos en uno de los nodos del clúster en la ruta HKEY_LOCAL_MACHINE/Cluster


5. A continuación vamos a ir a la clave HKEY_LOCAL_MACHINE\Cluster\Resources\9fde1b55-c399-4485-bfe6-048d8711da45\Parameters  . Dentro veremos el OBJECTGUID que tenía el objeto que se creó en su día.

6. Cambiaremos la clave ObjectGUID anterior por el código hexadecimal que copiamos en el punto 3.


7. Repetiremos los pasos 5 y 6 en todos los nodos del clúster.

8. A continuación resetearemos la cuenta que creamos en el primer punto.



Testeando la solución:

Iremos el clúster y haciendo click derecho sobre el recurso del nombre del clúster, elegiremos "More Actions - Repair".





Saludos.